System Requirements

System Requirements
System Requirements are minimal:

  • Window XP, XP Pro or any XP operating system with the exception of XP / 64 bit.
  • Screen Resolution minimum is 800x600.  All but the very oldest screens exceed this requirement.
  • Any chipset is good.
  • RAM:  256K is used exclusively for software.  Double that if not.
  • Hard Drive:  2GB or better open.
  • USB:  2.0 or latter.  We have successfully used USB 1 but it slows image and data transfer.

 

All our software runs on Window Operating Systems:

 

The following software will work only on Windows XP and XP-Pro:

  • Canon EOS 10D
  • Canon EOS 1D MK III
  • Canon EOS 1Ds MK III
  • Canon EOS 20D
  • Canon EOS 30D
  • Canon EOS 40D
  • Canon EOS 5D (MK I)
  • Canon EOS 300D
  • Canon EOS XS 1000D
  • Canon EOS XSi 450D
  • Canon EOS XT 350D
  • Canon EOS XTi 400D

The following software will work with Windows XP, XP-Pro, 7, 8 and 10 

  • Canon EOS 1D MK IV
  • Canon EOS 5D MK II
  • Canon EOS 7D
  • Canon EOS 50D
  • Canon EOS T1i_500D
  • Canon EOS T2i_550D
  • Canon EOS T3i_600D

The following software will work with Windows 7, 8 and 10  .. NO SUPPORT FOR ... XP and XP-Pro

  • Canon EOS 1D X
  • Canon EOS 5D MK III
  • Canon EOS 6D
  • Canon EOS 7D MK II
  • Canon EOS 60D
  • Canon EOS 70D
  • Canon EOS 100D
  • Canon EOS T4i 650D
  • Canon EOS T5i_Kiss 7i_700D
  • Canon EOS T3_1100D

 

Note for Windows 7/8 users.
With some configurations when you want to update, you may have to run the application as an administrator (just right-click on the program to do this, then select 'Run as administrator'). If you don't, you'll get an error like "There was an error running the install program. Please contact your vendor" when you try to update online.

 

 
Joomla Template: by JoomlaShack